0 votes
by Bruno Degazio (250 points)

I've been able to launch vfx in Terminal on an Apple M1 Laptop, but the performance is _very_ slow (about 60x slower than on my x86 machine), apparently due to a security feature in MacOS that disallows writing and executing code from the same memory block. 

Has anymore figured out a workaround for this? 

It can supposedly be turned off for specific applications by using the "Allow Execution of JIT-compiled Code Entitlement"  but that requires a lot of low-level Mach-O executable binary handling that is well beyond my expertise. 


Bruno Degazio

Sheridan College

Toronto , Canada

1 Answer

0 votes
by Daniel Lee (630 points)
edited by Daniel Lee

You can turn off this security system-wide without manipulating the VFX binary:

Disabling and Enabling System Integrity Protection

according to the Stack Overflow question, turning off System Integrity Protection eliminates the need to give VFX the "Allow Execution of JIT-compiled Code" entitlement.

Apple admits that turning off this write/ execution protection is sometimes necessary: "During development, it may be necessary for you to disable SIP temporarily to install and test your code."

by Bruno Degazio (250 points)
Thank you, Daniel. I will try that to see if it resolves the performance problem on the M1.